Sitecore: Content Editor Introduction

The Content Editor interface provides a multitude of features that allow you to create and maintain the content of your site. The Content
Editor in combination with two extra applications, Media Shop and Workbox, gives the user full control over the site content. The Content
Editor styling and functionality are inspired by Office 2007 and allow editors to simultaneously use the system and have the editing
options at hand. This document describes how to use the various Content Editor Interface features.

1. Content Editor Overview

The screenshot below shows the Content Editor as seen by a fully privileged user, such as admin. Please note that some
features and information is restricted for non-Administrator users, so the actual appearance of the Content Editor for a specific user may
vary. Nonetheless, the main areas of the editor described in this document are the same for all users.
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The topmost part of the Content Editor interface is the Ribbon where all the commands for editing content are located. To the left is the
content tree area. Select the View tab for instructions on viewing and hiding the content tree. To the right are the Item Title Bar and the
Field Area. At the bottom is the Pages Bar which provides access to Media Library and Workbox.



2. The Ribbon

The topmost part of the Content Editor is called the Ribbon. It provides access to Sitecore editing functionality. The Ribbon is comprised
of Tabs

The Ribbon in the screenshot below contains tabs that provide the various content maintenance related commands:
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In general, tabs provide groups of operation specific commands. A group of commands are called a Chunk, while a set of chunks is called
a Strip.

The screenshot below illustrates the terminology introduced so far:
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Note: Disabled commands are grayed out. The screenshot below shows the unfolded Navigate Chunk with the Back, Forward and
sub-items commands disabled.
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Note: The tabs available for the user will depend on the user's assigned roles and the security settings for the current installation.
Here we will describe options available to fully privileged users, also known as Administrators. If some of the functionality described here
is missing in a specific session, the current user may not have the necessary permissions.

The Home Tab

Commands provided by the Home tab allow you to manipulate the current item as a whole, such as copying the item, changing its
position in the content tree, or creating sub-items.
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When selected, the Home tab displays a strip ofsix chunks.
The Write Chunk

The Write chunk is always unfolded no matter which tab is activated and contains the Save button:



The Write Chunk

The Write chunk is always unfolded no matter which tab is activated and contains the Save button:

The Edit

Select to save changes to the currently selected item.

Chunk

The Edit chunk contains the Edit button:

Select Edit to lock the current item so that only you can edit it. If the button is disabled, this may mean that someone else has

the item locked, or that you do not have Write access rights on the item. When you have obtained a lock on the item, the Edit chunk
changes to display the Check In button.
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Select the Check In button to unlock the item so that other users may change it.

The Insert Chunk

The Insert chunk contains buttons for each of the types of sub-items that you can create under the current item. The list will vary
depending on which item is selected. If many item types are available, you can scroll to see additional item types. Select the appropriate

button to create a new sub-item of the corresponding type.
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The Operations Chunk

The Operations chunk contains the Duplicate, Copy To, Move To and Delete buttons:
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Duplicate  select to duplicate the currently selected item. The client will request a name for the duplicate item.

% Copy To ~
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Select to copy the item to another location. The client will request a location for the copy.

Select to move the Item to another location. Specify the desired location in the dialog which will appear.

Delete = Select to delete the current item.
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Select to delete sub-items.




The Rename Chunk

The Rename chunk contains the Rename and Display Name buttons:

Rename
T Display Mame

Rename Select to assign a new name to the item. This is the name that will be used in the URL required to select the item in the
published web site.

T Display Name Select to assign a new language-dependent name to the item.
The Sorting Chunk

The Sorting chunk contains the Up, Down, First and Last buttons.

Aup R First
W Down ¥ Last
Sorting Select the box beside the Sorting button to define how the sub-items of this item are sorted. In the Subitems

Sorting dialog, select the desired sorting from the drop-down menu of the Sorting field and click the OK button.
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Most sorting use the sortorder field as first criteria. You can reset the
sortorder field of the subitems by clicking the Reset button below.

[ OK [ Cancel

You can also reset the sortorder field of the sub-items by clicking the Reset button at the bottom of the Subitems Sorting dialog.

A Up

Select to move the item before the previous item.

% Down Select to move the item after the next item.

* First Select to move the item first.



i Last Select to move the item last.

2.2. The Navigate Tab

Commands provided by the tab change which item is selected.

When selected, the Navigate Tab displays the Navigate chunk:
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The Navigate chunk contains the Open, Back, Forward, Up, Subitems, Home, Favorites and Links buttons.

ﬁ Select to open an Item. In the dialog box which will appear, select the item that you wish to open and click Open (see the
screenshot below).
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Select the item that you wish to open.
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MName Description

= a content

“)) Home
B layout
* masters
(&) media library
%) system
& templates

Mame: |fsitecore/content!Home |

[ Open ] Cancel ]




The Open button marked in red in the screenshot below provides an additional option. When clicked, it displays the contextual menu of
two tabs. In addition to the Content Tree folder, the Recent folder lists recently visited Items:
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Back  Select to go to the previously selected item.

Forward  Select to return to an item after having selected the Back button.
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Up Select to go to the parent item.
r
Subltems ~  Select to go to a sub-item. Then select the desired sub-item in the sub-items menu which will appear.
Home

Select to go to the Home item.

e

Favorites ~  Select to display your favorite items.



Links = Select to show referenced and referred items. When selected, the Links button opens the list of referenced and referred items
(see the screenshot below).
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2.3. The Review Tab
Commands provided by the tab allow you to validate the item, perform workflow operations, or schedule future activities.

When clicked, the Review tab displays the Proofing, Workflow and Schedule chunks (see the screenshot below).
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The Proofing chunk contains the Spelling, Markup, and Validation buttons:
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Spelling Markup Validation
| Frooiing
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Speling  Select to check spelling in the entire item.

9

Markup - select to check that the HTML conforms to the XHTML standard specified by the W3C organization.

&

Validation

Select to validate the page contents.

The appearance of the Workflow chunk depends on the workflow state of the current item and the roles the user has assigned. Although
not described here, the Workflow chunk will also display any workflow related commands. Workflow related commands differ between
sites; contact your local administrator for information about workflow commands available at your site.



If the item is unlocked and the user has the appropriate permissions, the Workflow chunk with the Edit button and a prompt to click the
Edit button to lock and edit the item will appear (see the screenshot below).

Click the Edit button (/] Edit
to lock and edit this item.

Note: Any user with the Administrator permissions will still be able to edit the item even if it has been locked by another user. The
screenshot below shows the Workflow chunk any Administrator user will see:
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It the user does not have the appropriate permissions, this will be indicated in the Workflow chunk the user will see:

You do not have permission to
edit the content of this item.

The Schedule chunk contains the Reminder and the Archive buttons:
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Reminder ~  Select to set or clear the Reminder. Select the action you want to perform on the Select menu which will appear:
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Mo reminder has been set,
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Archive ©  Select to archive the item. It is possible to Archive the item now, set the archive date or clear the archive date via this
button. Select the desired option on the Archive menu which will appear:
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Retrieving items from the archive is an advanced operation not described here. Please use this feature with caution.

24. The Publish Tab

Commands provided by the Publish tab allow the user to preview and publish items.

When clicked, the Publish tab displays the Publish chunk.
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The Publish chunk contains the Publish, WebEdit, Preview and Publishing Viewer options (see the screenshot below).
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Publish = gelect to publish the item.

Preview
EB Select to start the Preview mode. The Preview interface will open in a new window.

7@7Publishhgf\fiewerf Select to open the Publishing Viewer (see the image below) which shows when items versions are active on
the website.
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3. The Content Tree

The Content Tree allows viewing the Sitecore system as a tree with child items grouped under their parents.
If an item has child items, a + appears next to it, as shown in the screenshot below:
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Click + to show the child items. Once the parent item has been expanded, a - appears next to it, as shown in the
image below:
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Once a - is clicked, the child items will be hidden.

When the user right clicks any item in the content tree, the context menu with a set of available commands for this item will appear. See
the screenshot below for an example of a menu.

Note: commands available on the menu will vary on a per item basis.
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4. The Field Area

The Field Area is located in the right side of the Content Editor, below the Item Title Bar and contains fields, which are grouped into
sections (see the screenshot below).
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5. The Media Library

The Media Library is a tool for storing, administering and uploading media files to the system. The Media Library allows you to handle
media files of various types: images, Word documents, PDF files, sound files, or movie clips. The media files stored in the Media Library
may be embedded into the website content. You may also provide links to them, which will allow the website visitors to download the
specified media files.

To access the Media Library, click the Media Library button on the Pages Bar, which is located at the bottom of the Content Editor
application window (see the screenshot below).
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Click the File button, and the "Upload a File" dialog will appear. You may manually type the path to the item into the appropriate field in
the dialog or you may click Browse and locate the necessary file. Then click the Upload button at the bottom of the dialog, which will
finish the upload process.
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Sitecore Media Library also allows you to upload multiple files with advanced options. To do that open the Media Library and select the
Upload Files (Advanced) item.

o

Advanced  gelect to upload files with advanced options. When selected, the Advanced button will open the "Batch Upload" dialog (see
the screenshot below).
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In the dialog, select the files to upload by manually typing the paths into the appropriate fields or by selecting the Browse button. When
done, select the upload button, which will finish the upload process. The newly uploaded files will appear in the "Uploaded Media Items"
box (see the screenshot above).





